aboutsummaryrefslogtreecommitdiff
path: root/gui/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/default.nix')
-rw-r--r--gui/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/gui/default.nix b/gui/default.nix
index 6948139..93cf8c3 100644
--- a/gui/default.nix
+++ b/gui/default.nix
@@ -9,14 +9,13 @@ in {
./kitty.nix
./vim.nix
./zathura.nix
- # desktop shortcuts for project specific tasks
- ./tasker.nix
# applications grouped by purpose
./apps/file.nix
./apps/web.nix
./apps/dev.nix
];
+# hidpi specific xorg flags
xresources.extraConfig = pkgs.lib.mkIf hidpi ''
Xft.dpi: 160
Xft.autohint: 0
@@ -26,4 +25,10 @@ in {
Xft.antialias: 1
Xft.rgba: rgb
'';
+
+# desktop shortcuts for project specific tasks
+ home.packages = pkgs.callPackage ./pkgs/tasker.nix {
+ inherit pkgs;
+ tasks = config.custom.tasks;
+ };
}