aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2023-01-02 11:54:20 +0100
committerAdrian Kummerlaender2023-01-02 11:54:20 +0100
commit8649a521f6c6e073e75fb101f2546a016bb87dda (patch)
treeb29c02e3407a50c1eed98cc50e78e4f383aded1a /shell.nix
parentd864699c5ddd744ee7376c0d752b6bbb771429a2 (diff)
downloadcompustream-master.tar
compustream-master.tar.gz
compustream-master.tar.bz2
compustream-master.tar.lz
compustream-master.tar.xz
compustream-master.tar.zst
compustream-master.zip
Flakeify buildHEADmaster
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index ce29a92..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-{ pkgs ? import <nixpkgs> { }, ... }:
-
-pkgs.stdenvNoCC.mkDerivation rec {
- name = "compustream-env";
- env = pkgs.buildEnv { name = name; paths = buildInputs; };
-
- buildInputs = with pkgs; [
- cmake
- universal-ctags
- gcc8
- gdb cgdb
- glfw3
- glew
- glm
- ];
-
- shellHook = ''
- export NIX_SHELL_NAME="${name}"
- '';
-}