aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index c57c8a5..026572b 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,12 +1,18 @@
with import <nixpkgs> {};
stdenv.mkDerivation rec {
- name = "env";
+ name = "computicle-env";
env = buildEnv { name = name; paths = buildInputs; };
+
buildInputs = [
+ fish
git cmake gcc gdb cgdb
glfw3
glew
glm
];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
}