summaryrefslogtreecommitdiff
path: root/host/obelix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-07-26 19:27:07 +0200
committerAdrian Kummerlaender2018-07-26 19:27:48 +0200
commit0749b4e023861357ae9cdd09c09d0a02bec6eea8 (patch)
tree966eaa7f44f6c2c09229f2de7294f70e2ccb50b2 /host/obelix.nix
parentb651482c5fbb395d0323f37a456e1afe2cfa282d (diff)
downloadnixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar.gz
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar.bz2
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar.lz
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar.xz
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.tar.zst
nixos_system-0749b4e023861357ae9cdd09c09d0a02bec6eea8.zip
Force correct TTY resolution on obelix
previous commit did not do the trick
Diffstat (limited to 'host/obelix.nix')
-rw-r--r--host/obelix.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/host/obelix.nix b/host/obelix.nix
index ae2d00b..5d6206c 100644
--- a/host/obelix.nix
+++ b/host/obelix.nix
@@ -4,12 +4,13 @@
imports = [ ./hardware/obelix.nix ];
boot = {
- kernelParams = [ "vga=0x034D" ];
-
loader.grub = {
- enable = true;
+ enable = true;
version = 2;
- device = "/dev/sdb";
+ device = "/dev/sdb";
+ extraConfig = ''
+ set gfxpayload=1920x1200x32
+ '';
};
initrd.luks.devices = [ {
@@ -22,7 +23,7 @@
systemd.services.spin-down-storage = {
enable = true;
- description = "Spin down storage drive by default";
+ description = "Spin down storage drive";
serviceConfig = {
Type = "oneshot";
ExecStart = "${pkgs.hdparm}/bin/hdparm -q -S 120 -y /dev/disk/by-label/storage";