summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix36
1 files changed, 1 insertions, 35 deletions
diff --git a/configuration.nix b/configuration.nix
index 6c293fe..3a4be5b 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -4,34 +4,12 @@
system.stateVersion = "18.03";
imports = [
- ./hardware-configuration.nix
+ ./host/current.nix
./conf/fish.nix
];
- boot = {
- kernelParams = [ "vga=0x31B" ];
-
- loader.grub = {
- enable = true;
- version = 2;
- device = "/dev/sdb";
- };
-
- initrd.luks.devices = [ {
- name = "root";
- device = "/dev/disk/by-uuid/6205da24-b1b2-402c-b175-4036e678dea9";
- preLVM = true;
- allowDiscards = true;
- } ];
- };
-
fileSystems."/".options = [ "noatime" "nodiratime" "discard" ];
- networking = {
- hostName = "obelix";
- firewall.enable = false;
- };
-
sound.enable = true;
hardware = {
opengl.driSupport32Bit = true;
@@ -79,8 +57,6 @@
layout = "de";
xkbOptions = "caps:escape";
- videoDrivers = [ "nvidiaBeta" ];
-
displayManager.slim = {
enable = true;
autoLogin = true;
@@ -91,16 +67,6 @@
};
};
- systemd.services.spin-down-storage = {
- enable = true;
- description = "Spin down storage drive by default";
- serviceConfig = {
- Type = "oneshot";
- ExecStart = "${pkgs.hdparm}/bin/hdparm -q -S 120 -y /dev/disk/by-label/storage";
- };
- wantedBy = [ "multi-user.target" ];
- };
-
users.extraUsers.common = {
isNormalUser = true;
uid = 1000;