summaryrefslogtreecommitdiff
path: root/host/athena.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/athena.nix')
-rw-r--r--host/athena.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/host/athena.nix b/host/athena.nix
index 211f155..b44fb67 100644
--- a/host/athena.nix
+++ b/host/athena.nix
@@ -12,12 +12,13 @@
efi.canTouchEfiVariables = true;
};
- initrd.luks.devices = [ {
- name = "encrypted";
- device = "/dev/nvme0n1p2";
- preLVM = true;
- allowDiscards = true;
- } ];
+ initrd.luks.devices = {
+ encrypted = {
+ device = "/dev/nvme0n1p2";
+ preLVM = true;
+ allowDiscards = true;
+ };
+ };
};
networking = {
@@ -92,10 +93,9 @@
powerManagement.powertop.enable = true;
- i18n = {
- consoleFont = "ter-132n";
- consolePackages = [ pkgs.terminus_font ];
+ console = {
+ earlySetup = true;
+ font = "ter-132n";
+ packages = [ pkgs.terminus_font ];
};
-
- boot.earlyVconsoleSetup = true;
}