summaryrefslogtreecommitdiff
path: root/host/automatix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/automatix.nix')
-rw-r--r--host/automatix.nix40
1 files changed, 4 insertions, 36 deletions
diff --git a/host/automatix.nix b/host/automatix.nix
index 9724b95..cbd0aeb 100644
--- a/host/automatix.nix
+++ b/host/automatix.nix
@@ -1,7 +1,10 @@
{ pkgs, ... }:
{
- imports = [ ./hardware/automatix.nix ];
+ imports = [
+ ./hardware/automatix.nix
+ ./software/code.kummerlaender.eu.nix
+ ];
boot.loader.grub = {
enable = true;
@@ -18,31 +21,6 @@
};
services = {
- gitea = {
- enable = true;
- database.type = "sqlite3";
-
- appName = "~/projects";
- domain = "code.kummerlaender.eu";
- rootUrl = "https://code.kummerlaender.eu/";
- httpPort = 3000;
-
- extraConfig = ''
- [server]
- LANDING_PAGE = "explore"
- [service]
- DISABLE_REGISTRATION = true
- SHOW_REGISTRATION_BUTTON = false
- [api]
- ENABLE_SWAGGER_ENDPOINT = false
- [picture]
- DISABLE_GRAVATAR = true
- [other]
- SHOW_FOOTER_VERSION = false
- SHOW_FOOTER_TEMPLATE_LOAD_TIME = false
- '';
- };
-
nginx = {
enable = true;
@@ -50,16 +28,6 @@
recommendedOptimisation = true;
recommendedProxySettings = true;
recommendedTlsSettings = true;
-
- virtualHosts."code.kummerlaender.eu" = {
- addSSL = true;
- enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://localhost:3000/";
- };
- };
- };
};
};
}