summaryrefslogtreecommitdiff
path: root/host/automatix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/automatix.nix')
-rw-r--r--host/automatix.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/host/automatix.nix b/host/automatix.nix
index cb75ed1..9967430 100644
--- a/host/automatix.nix
+++ b/host/automatix.nix
@@ -23,6 +23,17 @@
# open Nginx ports, other services open their own ports
allowedTCPPorts = [ 80 443 ];
};
+
+ # setup IPv6
+ interfaces.ens3.ipv6.addresses = [ {
+ address = "2a01:4f8:c010:f56::1";
+ prefixLength = 64;
+ } ];
+
+ defaultGateway6 = {
+ address = "fe80::1";
+ interface = "ens3";
+ };
};
services = {