summaryrefslogtreecommitdiff
path: root/host/hardware/asterix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/hardware/asterix.nix')
-rw-r--r--host/hardware/asterix.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/host/hardware/asterix.nix b/host/hardware/asterix.nix
new file mode 100644
index 0000000..a0412d5
--- /dev/null
+++ b/host/hardware/asterix.nix
@@ -0,0 +1,31 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/2f564c2d-d300-4712-a578-1cd77fcaa40d";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/ded323eb-84de-4ff5-8570-8f50e93a862e";
+ fsType = "ext2";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/79b17f7c-a47e-45ea-b755-d05065a05734"; }
+ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}