summaryrefslogtreecommitdiff
path: root/host/hardware/automatix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/hardware/automatix.nix')
-rw-r--r--host/hardware/automatix.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/hardware/automatix.nix b/host/hardware/automatix.nix
new file mode 100644
index 0000000..4b35109
--- /dev/null
+++ b/host/hardware/automatix.nix
@@ -0,0 +1,25 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "sd_mod" "sr_mod" ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/ec324e84-6766-49b7-ad5e-583e78a35432";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/05f0315c-f5f5-4471-b2ef-6e53b95cb08b"; }
+ ];
+
+ nix.maxJobs = lib.mkDefault 1;
+}