summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
index 8d5aab7..da855d6 100644
--- a/host/majestix.nix
+++ b/host/majestix.nix
@@ -45,4 +45,23 @@
nssmdns = true;
};
};
+
+ hardware.opengl.extraPackages = [ pkgs.intel-ocl ];
+
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.3/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
}