summaryrefslogtreecommitdiff
path: root/host/software/server/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/software/server/git.nix')
-rw-r--r--host/software/server/git.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/host/software/server/git.nix b/host/software/server/git.nix
new file mode 100644
index 0000000..4eedb53
--- /dev/null
+++ b/host/software/server/git.nix
@@ -0,0 +1,38 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitea = {
+ enable = true;
+ database.type = "sqlite3";
+
+ appName = "~/projects";
+ domain = "code.kummerlaender.eu";
+ rootUrl = "https://code.kummerlaender.eu/";
+ httpPort = 3000;
+
+ extraConfig = ''
+ [server]
+ LANDING_PAGE = "explore"
+ [service]
+ DISABLE_REGISTRATION = true
+ SHOW_REGISTRATION_BUTTON = false
+ [other]
+ SHOW_FOOTER_VERSION = false
+ SHOW_FOOTER_TEMPLATE_LOAD_TIME = false
+ [api]
+ ENABLE_SWAGGER_ENDPOINT = false
+ [picture]
+ DISABLE_GRAVATAR = true
+ [indexer]
+ REPO_INDEXER_ENABLED = true
+ '';
+ };
+
+ nginx.virtualHosts."code.kummerlaender.eu" = {
+ addSSL = true;
+ enableACME = true;
+ locations."/".proxyPass = "http://localhost:3000/";
+ };
+ };
+}