summaryrefslogtreecommitdiff
path: root/pkgs/xslt/input-xslt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/xslt/input-xslt/default.nix')
-rw-r--r--pkgs/xslt/input-xslt/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/xslt/input-xslt/default.nix b/pkgs/xslt/input-xslt/default.nix
new file mode 100644
index 0000000..cd28a67
--- /dev/null
+++ b/pkgs/xslt/input-xslt/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, fetchFromGitHub, cmake, boost, xalanc, xercesc, discount }:
+
+stdenv.mkDerivation rec {
+ name = "input-xslt";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "InputXSLT";
+ rev = "master";
+ sha256 = "1j9fld3sh1jyscnsx6ab9jn5x6q67rjh9p3bgsh5na1qrs40dql0";
+ };
+
+ buildInputs = [ cmake boost xalanc xercesc discount ];
+
+ meta = with stdenv.lib; {
+ description = "InputXSLT";
+ homepage = https://github.com/KnairdA/InputXSLT/;
+ license = stdenv.lib.licenses.asl20;
+ };
+}