aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2014-09-16 19:57:28 +0200
committerAdrian Kummerlaender2014-09-16 19:57:28 +0200
commit0e3cfcde619fb60e6e43bf0ffe715df6d5c22218 (patch)
treede4eba6323b29e30e4d226ba1a905ba9bd12714b /CMakeLists.txt
parent9db4e054627eb30b4e5a7333405c423df5a8d490 (diff)
downloadSimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar.gz
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar.bz2
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar.lz
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar.xz
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.tar.zst
SimpleParser-0e3cfcde619fb60e6e43bf0ffe715df6d5c22218.zip
Improved lexer readabilty and replaced raw new in tree construction
* "new" in Tree::addNode member method was replaced with C++14 std::make_unique * renamed and constified lexer local variables to increase readabilty ** replaced chunky if-clauses with switch-clauses where appropriate * updated README.md to mention C++14 requirement
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06663a0..dabc978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ project(SimpleParser)
set(
CMAKE_CXX_FLAGS
- "-std=c++11 -W -Wall -Wextra -Winline -pedantic"
+ "-std=c++14 -W -Wall -Wextra -Winline -pedantic"
)
add_library(