aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2014-09-27 18:36:56 +0200
committerAdrian Kummerlaender2014-09-27 18:36:56 +0200
commit6498a968cd34e49e355cc0765ca2dafb842bc12b (patch)
treec9f5459ad78454c124591260d334cae1eb599e84 /CMakeLists.txt
parent5a1ee058e1c0f4e6f2a37f0c302671d73b66b0b7 (diff)
downloadSimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar.gz
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar.bz2
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar.lz
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar.xz
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.tar.zst
SimpleParser-6498a968cd34e49e355cc0765ca2dafb842bc12b.zip
Added argument and tree export mode to frontend
* arguments are managed through boost::program_options * default continues to be the REPL * "--tree" argument switches from calculation to tree export * "--input" may be used to pass terms to be evaluated via CLI arguments ** disables REPL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dabc978..763be29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ add_library(
)
add_executable(
- test
+ tests
test.cc
)
@@ -26,7 +26,7 @@ add_executable(
)
target_link_libraries(
- test
+ tests
SimpleParser
gtest
)
@@ -34,9 +34,10 @@ target_link_libraries(
target_link_libraries(
clc
SimpleParser
+ boost_program_options
)
add_custom_command(
- TARGET test
- POST_BUILD COMMAND ./test
+ TARGET tests
+ POST_BUILD COMMAND ./tests
)