aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..06663a0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,42 @@
+cmake_minimum_required(VERSION 2.8)
+project(SimpleParser)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++11 -W -Wall -Wextra -Winline -pedantic"
+)
+
+add_library(
+ SimpleParser
+ SHARED
+ src/nodes.cc
+ src/tree.cc
+ src/utils.cc
+ src/parser.cc
+)
+
+add_executable(
+ test
+ test.cc
+)
+
+add_executable(
+ clc
+ clc.cc
+)
+
+target_link_libraries(
+ test
+ SimpleParser
+ gtest
+)
+
+target_link_libraries(
+ clc
+ SimpleParser
+)
+
+add_custom_command(
+ TARGET test
+ POST_BUILD COMMAND ./test
+)