aboutsummaryrefslogtreecommitdiff
path: root/SimpleParser.nix
diff options
context:
space:
mode:
Diffstat (limited to 'SimpleParser.nix')
-rw-r--r--SimpleParser.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/SimpleParser.nix b/SimpleParser.nix
new file mode 100644
index 0000000..1a56271
--- /dev/null
+++ b/SimpleParser.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchFromGitHub, cmake, boost, gtest }:
+
+stdenv.mkDerivation rec {
+ name = "SimpleParser";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "SimpleParser";
+ rev = "v1.1";
+ sha256 = "1i38nrb28g1nzhcs0139arz8vvbnli9ryvdl657dqslb6ms1x0g2";
+ };
+
+ buildInputs = [ cmake boost gtest ];
+
+ meta = with stdenv.lib; {
+ homepage = https://github.com/KnairdA/SimpleParser/;
+ };
+}