aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2015-01-15 19:09:55 +0100
committerAdrian Kummerlaender2015-01-15 19:09:55 +0100
commitf32004323eae427cba2d25d01836367b291e522d (patch)
tree95481f9fb5558b6e56e3796b4a0f62e5ac7a1ed7 /CMakeLists.txt
downloadTypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar.gz
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar.bz2
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar.lz
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar.xz
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.tar.zst
TypeAsValue-f32004323eae427cba2d25d01836367b291e522d.zip
Initial project structure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ed284d4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.8)
+project(TypeAsValue)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++14 -W -Wall -Wextra -Winline -pedantic"
+)
+
+include_directories(
+ src/
+)
+
+add_executable(
+ tests
+ test.cc
+)
+
+target_link_libraries(
+ tests
+ gtest
+)
+
+add_custom_command(
+ TARGET tests
+ POST_BUILD COMMAND ./tests
+)