aboutsummaryrefslogtreecommitdiff
path: root/example/prime/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2015-02-04 17:38:49 +0100
committerAdrian Kummerlaender2015-02-04 17:38:49 +0100
commit7eef405eeff59c27691be294906e8381a76771e2 (patch)
tree3dacd93798eabc5a467f9104850f87d071ba579d /example/prime/CMakeLists.txt
parent6d150b7d5a2c65a54203608e398ed38e48ed36e3 (diff)
downloadTypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar.gz
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar.bz2
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar.lz
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar.xz
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.tar.zst
TypeAsValue-7eef405eeff59c27691be294906e8381a76771e2.zip
Implemented the Sieve of Eratosthenes as a basic example
Diffstat (limited to 'example/prime/CMakeLists.txt')
-rw-r--r--example/prime/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/example/prime/CMakeLists.txt b/example/prime/CMakeLists.txt
new file mode 100644
index 0000000..7c7a757
--- /dev/null
+++ b/example/prime/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8)
+project(prime)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++14 -W -Wall -Wextra -Winline -pedantic -ftemplate-depth-1024"
+)
+
+include_directories(
+ ../../src/
+)
+
+add_executable(
+ prime
+ prime.cc
+)