aboutsummaryrefslogtreecommitdiff
path: root/example/turing/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2015-02-21 14:56:39 +0100
committerAdrian Kummerlaender2015-02-21 14:56:39 +0100
commiteffddfdd69cf9e5ec700aeda2980c0210575e320 (patch)
tree241f03911920723c38c1d216d56ae7858e2cba24 /example/turing/CMakeLists.txt
parentde1f1dc67a1dabcddac2e89a5d703e98a92b7f11 (diff)
downloadTypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar.gz
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar.bz2
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar.lz
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar.xz
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.tar.zst
TypeAsValue-effddfdd69cf9e5ec700aeda2980c0210575e320.zip
Implemented basic Turing machine as an example
* executes and prints the _Busy Beaver_ and _Mirror_ state transitions * this example demonstrates how one may use _TypeAsValue_ to simplify and augment normal statically recursive template metaprograms where it makes sense
Diffstat (limited to 'example/turing/CMakeLists.txt')
-rw-r--r--example/turing/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/example/turing/CMakeLists.txt b/example/turing/CMakeLists.txt
new file mode 100644
index 0000000..dc08ac9
--- /dev/null
+++ b/example/turing/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8)
+project(turing)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++14 -W -Wall -Wextra -Winline -pedantic -ftemplate-depth-1024"
+)
+
+include_directories(
+ ../../src/
+)
+
+add_executable(
+ turing
+ turing.cc
+)