aboutsummaryrefslogtreecommitdiff
path: root/InputXSLT.nix
diff options
context:
space:
mode:
Diffstat (limited to 'InputXSLT.nix')
-rw-r--r--InputXSLT.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/InputXSLT.nix b/InputXSLT.nix
new file mode 100644
index 0000000..6c1f473
--- /dev/null
+++ b/InputXSLT.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchFromGitHub, cmake, boost, xalanc, xercesc, discount }:
+
+stdenv.mkDerivation rec {
+ name = "InputXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "InputXSLT";
+ rev = "master";
+ sha256 = "1j9fld3sh1jyscnsx6ab9jn5x6q67rjh9p3bgsh5na1qrs40dql0";
+ };
+
+ buildInputs = [ cmake boost xalanc xercesc discount ];
+
+ meta = with stdenv.lib; {
+ homepage = https://github.com/KnairdA/InputXSLT/;
+ };
+}