aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..bd65829
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation rec {
+ name = "env";
+ env = buildEnv { name = name; paths = buildInputs; };
+ buildInputs = let
+ InputXSLT = callPackage ./InputXSLT.nix {};
+ in [
+ InputXSLT
+ pandoc
+ highlight
+ nodejs
+ python3
+ ];
+}