aboutsummaryrefslogtreecommitdiff
path: root/gui/autorandr.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-15 14:58:03 +0200
committerAdrian Kummerlaender2018-09-15 14:58:03 +0200
commit4c221de75d4ef123808d77057081f029490a628f (patch)
tree5f1da390966e709ab213ac533cf4f912b94fc8e1 /gui/autorandr.nix
parent3bcdfb712b72b1f856549d96037e59ce50413aa6 (diff)
downloadnixos_home-4c221de75d4ef123808d77057081f029490a628f.tar
nixos_home-4c221de75d4ef123808d77057081f029490a628f.tar.gz
nixos_home-4c221de75d4ef123808d77057081f029490a628f.tar.bz2
nixos_home-4c221de75d4ef123808d77057081f029490a628f.tar.lz
nixos_home-4c221de75d4ef123808d77057081f029490a628f.tar.xz
nixos_home-4c221de75d4ef123808d77057081f029490a628f.tar.zst
nixos_home-4c221de75d4ef123808d77057081f029490a628f.zip
Add basic multihead setup for docked asterix
Diffstat (limited to 'gui/autorandr.nix')
-rw-r--r--gui/autorandr.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/gui/autorandr.nix b/gui/autorandr.nix
new file mode 100644
index 0000000..457417e
--- /dev/null
+++ b/gui/autorandr.nix
@@ -0,0 +1,42 @@
+{ pkgs, ... }:
+
+{
+ programs.autorandr = {
+ enable = true;
+
+ profiles = {
+ "mobile" = {
+ fingerprint = {
+ LVDS1 = "00ffffffffffff0030e4d3020000000000150103801c1078ea10a59658578f2820505400000001010101010101010101010101010101381d56d45000163030202500159c1000001b000000000000000000000000000000000000000000fe004c4720446973706c61790a2020000000fe004c503132355748322d544c423100f7";
+ };
+ config = {
+ LVDS1 = {
+ enable = true;
+ primary = true;
+ mode = "1366x768";
+ position = "0x0";
+ };
+ };
+ };
+ "docked" = {
+ fingerprint = {
+ LVDS1 = "00ffffffffffff0030e4d3020000000000150103801c1078ea10a59658578f2820505400000001010101010101010101010101010101381d56d45000163030202500159c1000001b000000000000000000000000000000000000000000fe004c4720446973706c61790a2020000000fe004c503132355748322d544c423100f7";
+ HDMI3 = "00ffffffffffff0010ac0d404a574841020f010380261f78eeee95a3544c99260f5054a54b00714f8180010101010101010101010101302a009851002a4030701300782d1100001e000000ff0054363131373531344148574a0a000000fc0044454c4c203139303546500a20000000fd00384c1e510e000a20202020202000e6";
+ };
+ config = {
+ LVDS1 = {
+ enable = true;
+ primary = true;
+ mode = "1366x768";
+ position = "0x256";
+ };
+ HDMI3 = {
+ enable = true;
+ mode = "1280x1024";
+ position = "1366x0";
+ };
+ };
+ };
+ };
+ };
+}