aboutsummaryrefslogtreecommitdiff
path: root/gui/emacs.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-06-22 00:34:17 +0200
committerAdrian Kummerlaender2020-06-22 00:34:17 +0200
commit5fcd04ac67c94d4ca249a8f212ebb5b423716454 (patch)
treed9e83dd428002d735a5666eebef217fec0ed4090 /gui/emacs.nix
parentcf8075b7b2f5cd049c0a0ef46b9c8627daab4d09 (diff)
downloadnixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar.gz
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar.bz2
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar.lz
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar.xz
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.tar.zst
nixos_home-5fcd04ac67c94d4ca249a8f212ebb5b423716454.zip
Setup emacs daemon and client
It seems like I finally got my setup to a state where Emacs is there to stay.
Diffstat (limited to 'gui/emacs.nix')
-rw-r--r--gui/emacs.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/gui/emacs.nix b/gui/emacs.nix
index e6fab00..e213fe9 100644
--- a/gui/emacs.nix
+++ b/gui/emacs.nix
@@ -62,4 +62,9 @@
mkdir -p ~/.emacs.d
ln -s ${toString ./conf/init.el} ~/.emacs.d/init.el
'';
+
+ services.emacs = {
+ enable = true;
+ client.enable = true;
+ };
}