aboutsummaryrefslogtreecommitdiff
path: root/gui/emacs.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-08-29 10:28:08 +0200
committerAdrian Kummerlaender2020-08-29 10:28:08 +0200
commitc4a114a5b30a3bace11e27345d15fc9a922701fc (patch)
tree1cf1f2b1ada954f9289e9e971e39cf5ffc29ede9 /gui/emacs.nix
parent199b699e089ff00460ead86eeaa625c6bfa10f3d (diff)
downloadnixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar.gz
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar.bz2
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar.lz
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar.xz
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.tar.zst
nixos_home-c4a114a5b30a3bace11e27345d15fc9a922701fc.zip
Force usage of more up-to-date external org version
This is almost certainly not the simplest way of doing this but as the derivation builds Emacs anyway it doesn't cost anything to remove the builtin version of org.
Diffstat (limited to 'gui/emacs.nix')
-rw-r--r--gui/emacs.nix20
1 files changed, 15 insertions, 5 deletions
diff --git a/gui/emacs.nix b/gui/emacs.nix
index a0cd3bd..37c135b 100644
--- a/gui/emacs.nix
+++ b/gui/emacs.nix
@@ -32,8 +32,8 @@ in {
(add-to-list 'exec-path "${tex}/bin")
(add-to-list 'exec-path "${pkgs.graphviz}/bin")
(add-to-list 'exec-path "${pkgs.sqlite}/bin")
-
- (setq counsel-etags-update-tags-backend (lambda (src-dir) (shell-command "${pkgs.universal-ctags}/bin/ctags -e -R")))
+ (add-to-list 'exec-path "${pkgs.universal-ctags}/bin")
+ (add-to-list 'exec-path "${pkgs.global}/bin")
'';
};
@@ -51,11 +51,21 @@ in {
package = pkgs-unstable.emacsWithPackagesFromUsePackage {
config = ./conf/init.el;
- package = pkgs-unstable.emacsGcc;
- extraEmacsPackages = epkgs: with epkgs.melpaPackages; [
+ # remove builtin org as in https://github.com/chrisbarrett/.emacs.d/blob/6efd82c8e328e677dbef84331ed54763b89667a3/default.nix
+ # this is a workaround until I find a better way to force usage of a non-builtin up-to-date org version
+ package = pkgs-unstable.emacsGcc.overrideAttrs (old: {
+ patches = old.patches ++ [
+ ./patch/optional-org-gnus.patch
+ ];
+ postPatch = ''
+ ${old.postPatch}
+ rm -r test/lisp/org lisp/org etc/org etc/ORG-NEWS doc/misc/org.texi
+ '';
+ });
+ extraEmacsPackages = epkgs: (with epkgs.melpaPackages; [
pdf-tools
mu4e-alert
- ] ++ [
+ ]) ++ [
akr-color-theme
custom-runtime-env
pkgs.mu