aboutsummaryrefslogtreecommitdiff
path: root/gui/htop.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-06-09 20:52:41 +0200
committerAdrian Kummerlaender2021-06-09 20:52:41 +0200
commit66a233a6e234eaabac8ee50f15c86ff2c1700b8d (patch)
treeedcff1f679ff71ee3619df1883de101632d74cfa /gui/htop.nix
parentcf9d12cc6e6b01dad6a16f56053fdb128dde7274 (diff)
downloadnixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar.gz
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar.bz2
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar.lz
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar.xz
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.tar.zst
nixos_home-66a233a6e234eaabac8ee50f15c86ff2c1700b8d.zip
Update htop config
Diffstat (limited to 'gui/htop.nix')
-rw-r--r--gui/htop.nix19
1 files changed, 12 insertions, 7 deletions
diff --git a/gui/htop.nix b/gui/htop.nix
index 0cf1cbf..bb1f2bf 100644
--- a/gui/htop.nix
+++ b/gui/htop.nix
@@ -4,12 +4,17 @@
programs.htop = {
enable = true;
- treeView = true;
- showProgramPath = false;
- highlightBaseName = true;
- hideThreads = true;
- hideUserlandThreads = true;
- meters.left = [ "LeftCPUs4" "Memory" "Swap" ];
- meters.right = [ "RightCPUs4" "Tasks" "LoadAverage" "Uptime" ];
+ settings = {
+ treeView = true;
+
+ showProgramPath = false;
+ highlightBaseName = true;
+
+ hideThreads = true;
+ hideUserlandThreads = true;
+
+ left_meter_modes = [ "LeftCPUs4" "Memory" "Swap" ];
+ right_meter_modes = [ "RightCPUs4" "Tasks" "LoadAverage" "Uptime" ];
+ };
};
}