aboutsummaryrefslogtreecommitdiff
path: root/gui/stalonetray.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-01-25 21:43:01 +0100
committerAdrian Kummerlaender2019-01-31 20:36:04 +0100
commita576fc0630c4eed5263f29ab671b7f4a26f2a698 (patch)
treee78a3ee0b5d1f6464841905a31803ee207f8bc0c /gui/stalonetray.nix
parentbb54253133465a2425f95196e7364b0a13336562 (diff)
downloadnixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar.gz
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar.bz2
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar.lz
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar.xz
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.tar.zst
nixos_home-a576fc0630c4eed5263f29ab671b7f4a26f2a698.zip
Add stalonetray and nm-applet autostart on athena
It took me more time than it should have to get stalonetray to display below all windows as a _widget_ on the desktop...
Diffstat (limited to 'gui/stalonetray.nix')
-rw-r--r--gui/stalonetray.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/gui/stalonetray.nix b/gui/stalonetray.nix
new file mode 100644
index 0000000..ca3baaf
--- /dev/null
+++ b/gui/stalonetray.nix
@@ -0,0 +1,20 @@
+{ pkgs, ... }:
+
+{
+ services.stalonetray = {
+ enable = true;
+
+ config = {
+ decorations = "none";
+ icon_size = 48;
+ geometry = "5x1+10-10";
+ transparent = false;
+ grow_gravity = "E";
+ background = "#000000";
+ dockapp_mode = "none";
+ window_layer = "bottom";
+ window_strut = "bottom";
+ window_type = "dock";
+ };
+ };
+}