aboutsummaryrefslogtreecommitdiff
path: root/gui/xmonad.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-05-05 13:14:11 +0200
committerAdrian Kummerlaender2018-05-05 13:14:11 +0200
commitdadd30ae95c473a8614751f8bf41b26667140f1a (patch)
tree072fd3350e088d098316cdb60a2fc707e6b89ad1 /gui/xmonad.nix
parentdea9a66fccca94ed27387246e384f3dcb20501f6 (diff)
downloadnixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar.gz
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar.bz2
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar.lz
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar.xz
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.tar.zst
nixos_home-dadd30ae95c473a8614751f8bf41b26667140f1a.zip
Add X cursor config
Diffstat (limited to 'gui/xmonad.nix')
-rw-r--r--gui/xmonad.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/gui/xmonad.nix b/gui/xmonad.nix
index 85f86c2..da7d73a 100644
--- a/gui/xmonad.nix
+++ b/gui/xmonad.nix
@@ -1,9 +1,19 @@
{ pkgs, ... }:
{
- xsession.windowManager.xmonad = {
+ xsession = {
enable = true;
- enableContribAndExtras = true;
- config = ./conf/xmonad.hs;
+
+ pointerCursor = {
+ package = pkgs.vanilla-dmz;
+ name = "Vanilla-DMZ-AA";
+ size = 16;
+ };
+
+ windowManager.xmonad = {
+ enable = true;
+ enableContribAndExtras = true;
+ config = ./conf/xmonad.hs;
+ };
};
}