aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-08-27 21:10:56 +0200
committerAdrian Kummerlaender2020-08-27 21:10:56 +0200
commit290c1c8116cd70cc248cf4bb9458611a16c5694a (patch)
tree7a2e824dd593e31ba5878b419460d543473d85a3 /shell.nix
parent191438718de6175cb0cff457005ed312cc4e8fd8 (diff)
downloadnixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.gz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.bz2
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.lz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.xz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.zst
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.zip
Use niv for tracking channel versions
This way the config is actually reproducible without manually tracking supported nixpkgs states. home-manager is now not installed environment-wide anymore but only available inside a nix-shell.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..1e28dc1
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,18 @@
+let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs { };
+
+in pkgs.mkShell rec {
+ name = "home-manager";
+
+ buildInputs = [
+ pkgs.niv
+ (import sources.home-manager { inherit pkgs; }).home-manager
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ export NIX_PATH="nixpkgs=${sources.nixpkgs}:home-manager=${sources.home-manager}"
+ '';
+
+}