aboutsummaryrefslogtreecommitdiff
path: root/gui/apps/file.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/apps/file.nix')
-rw-r--r--gui/apps/file.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/gui/apps/file.nix b/gui/apps/file.nix
new file mode 100644
index 0000000..d366621
--- /dev/null
+++ b/gui/apps/file.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+
+{
+ home = {
+ packages = with pkgs; [
+ # browser
+ pcmanfm
+ # automounting
+ gvfs lxmenu-data shared_mime_info
+ # tools
+ veracrypt
+ # viewers
+ evince
+ sxiv
+ mpv
+ libreoffice
+ ];
+
+ sessionVariables = {
+ # required to enable auto-mounting in pcmanfm
+ GIO_EXTRA_MODULES = [ "${pkgs.gvfs}/lib/gio/modules" ];
+ # use GTK theme in libreoffice
+ SAL_USE_VCLPLUGIN = "gtk";
+ };
+
+ file.".config/user-dirs.dirs".text = ''
+ XDG_TEMPLATES_DIR="$HOME/"
+ XDG_DESKTOP_DIR="$HOME/"
+ XDG_DOWNLOADS_DIR="$HOME/downloads/"
+ '';
+ };
+}