aboutsummaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/home.nix b/home.nix
index 3f87e95..27a9bba 100644
--- a/home.nix
+++ b/home.nix
@@ -1,21 +1,14 @@
-{ config, pkgs, ... }:
+{ config, pkgs, pkgs-personal, ... }:
-let
- sources = import ./nix/sources.nix;
- pkgs = import sources.nixpkgs { };
- pkgs-unstable = import sources.nixpkgs-unstable { };
- pkgs-personal = import sources.mypkgs { };
-
-in {
- _module.args.sources = sources;
- _module.args.pkgs-unstable = pkgs-unstable;
- _module.args.pkgs-personal = pkgs-personal;
-
- imports = [
+{
+ imports = let
+ # impure access to system config
+ hostname = (import <nixpkgs/nixos> { }).config.networking.hostName;
+ in [
# define options custom to this config
./custom.nix
# load host specific stuff
- ./host/current.nix
+ (./host + ("/" + hostname + ".nix"))
# task shortcuts
./module/tasker.nix
./tasks/default.nix