summaryrefslogtreecommitdiff
path: root/host/hephaestus.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-06-08 10:04:39 +0200
committerAdrian Kummerlaender2021-06-08 10:04:39 +0200
commit5d5f71e108cb4559a3a8144fbd089076b61a9dda (patch)
treea835af8c2bfe4ad80c2cb2859def5e7b4e1b35b9 /host/hephaestus.nix
parent949787c8b5fdfcfa0d18c892b30b81c9a7d537a2 (diff)
downloadnixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar.gz
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar.bz2
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar.lz
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar.xz
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.tar.zst
nixos_system-5d5f71e108cb4559a3a8144fbd089076b61a9dda.zip
Add hephaestus config
Diffstat (limited to 'host/hephaestus.nix')
-rw-r--r--host/hephaestus.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/host/hephaestus.nix b/host/hephaestus.nix
new file mode 100644
index 0000000..ee3d128
--- /dev/null
+++ b/host/hephaestus.nix
@@ -0,0 +1,54 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ./hardware/hephaestus.nix
+ ./software/desktop
+ ];
+
+ boot = {
+ loader = {
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 3;
+ };
+ efi.canTouchEfiVariables = true;
+ };
+
+ initrd.luks.devices = {
+ encrypted = {
+ device = "/dev/nvme0n1p5";
+ preLVM = true;
+ allowDiscards = true;
+ };
+ };
+ };
+
+ networking = {
+ hostName = "hephaestus";
+ firewall.enable = false;
+ };
+
+ services.xserver.videoDrivers = [ "nvidia" ];
+ hardware.nvidia.package = pkgs.linuxPackages.nvidia_x11;
+
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.7/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
+
+ system.stateVersion = "21.05";
+}