aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2016-12-09 23:28:46 +0100
committerAdrian Kummerlaender2016-12-09 23:28:46 +0100
commitb72dcd74717366f145b029d89ae11a085a5f5997 (patch)
treec90959183927ee1e9adc3dc08c631e2ae17f79ef /CMakeLists.txt
downloadtermlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar.gz
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar.bz2
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar.lz
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar.xz
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.tar.zst
termlife-b72dcd74717366f145b029d89ae11a085a5f5997.zip
Initial working version
...of a plain Game Of Life displayed using `Termbox`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d517ca3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.8)
+project(life)
+
+set(
+ CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} -std=c++14 -W -Wall -Wextra -Winline -pedantic"
+)
+
+include_directories(
+ src/
+)
+
+add_executable(
+ life
+ life.cc
+)
+
+target_link_libraries(
+ life
+ termbox
+)