aboutsummaryrefslogtreecommitdiff
path: root/gui/touchegg.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-01-29 20:27:38 +0100
committerAdrian Kummerlaender2019-01-31 20:36:04 +0100
commit02adc98ce764eacdbd6ac2f2d20aaf893349868c (patch)
treeec5fd6cec07fe5c808eb6f3cbed5d30db769a883 /gui/touchegg.nix
parent72238630db12c37306e6ee336fa31bf6c550a37c (diff)
downloadnixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar.gz
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar.bz2
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar.lz
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar.xz
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.tar.zst
nixos_home-02adc98ce764eacdbd6ac2f2d20aaf893349868c.zip
Add basic touchegg setup for athena
Diffstat (limited to 'gui/touchegg.nix')
-rw-r--r--gui/touchegg.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/gui/touchegg.nix b/gui/touchegg.nix
new file mode 100644
index 0000000..9b74195
--- /dev/null
+++ b/gui/touchegg.nix
@@ -0,0 +1,24 @@
+{ pkgs, ... }:
+
+{
+ home.packages = [ pkgs.touchegg ];
+
+ home.file.".config/touchegg/touchegg.conf".source = ./conf/touchegg.conf;
+
+ systemd.user.services.touchegg = {
+ Unit = {
+ Description = "Touchégg multitouch gestures";
+ After = [ "graphical-session-pre.target" ];
+ PartOf = [ "graphical-session.target" ];
+ };
+
+ Install = {
+ WantedBy = [ "graphical-session.target" ];
+ };
+
+ Service = {
+ ExecStart = "${pkgs.touchegg}/bin/touchegg";
+ Restart = "on-failure";
+ };
+ };
+}