aboutsummaryrefslogtreecommitdiff
path: root/gui/rofi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/rofi.nix')
-rw-r--r--gui/rofi.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/gui/rofi.nix b/gui/rofi.nix
new file mode 100644
index 0000000..f2a9eca
--- /dev/null
+++ b/gui/rofi.nix
@@ -0,0 +1,55 @@
+{ pkgs, ... }:
+
+{
+ programs.rofi = {
+ enable = true;
+ location = "top";
+ font = "Iosevka 12";
+ separator = "none";
+ scrollbar = false;
+ borderWidth = 6;
+ yoffset = -6;
+
+ colors = {
+ window = {
+ background = "#222222";
+ border = "#aadb0f";
+ separator = "#000000";
+ };
+ rows = {
+ normal = {
+ background = "#222222";
+ foreground = "#8e8e8e";
+ backgroundAlt = "#161616";
+ highlight = {
+ background = "#111111";
+ foreground = "#aadb0f";
+ };
+ };
+ active = {
+ background = "#222222";
+ foreground = "#8e8e8e";
+ backgroundAlt = "#161616";
+ highlight = {
+ background = "#111111";
+ foreground = "#aadb0f";
+ };
+ };
+ urgent = {
+ background = "#222222";
+ foreground = "#dc322f";
+ backgroundAlt = "#161616";
+ highlight = {
+ background = "#dc322f";
+ foreground = "#161616";
+ };
+ };
+ };
+ };
+
+ extraConfig = ''
+ rofi.modi: combi
+ rofi.combi-modi: windowcd,drun,ssh
+ '';
+ };
+}