aboutsummaryrefslogtreecommitdiff
path: root/gui/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/vim.nix')
-rw-r--r--gui/vim.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/gui/vim.nix b/gui/vim.nix
index 95873ce..cc2d906 100644
--- a/gui/vim.nix
+++ b/gui/vim.nix
@@ -8,6 +8,17 @@
set linespace=2
set guioptions=agi
'';
+
+ # nvim-qt using vim configuration
+ packages = let
+ nvim-gui = import ./pkgs/nvim-gui.nix pkgs;
+ in [
+ nvim-gui
+ ];
+
+ file.".config/nvim/ginit.vim".text = ''
+ Guifont! Iosevka:h10
+ '';
};
gtk = {