aboutsummaryrefslogtreecommitdiff
path: root/gui/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/vim.nix')
-rw-r--r--gui/vim.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/gui/vim.nix b/gui/vim.nix
new file mode 100644
index 0000000..1b2c4db
--- /dev/null
+++ b/gui/vim.nix
@@ -0,0 +1,21 @@
+{ pkgs, ... }:
+
+{
+ home = {
+ # vim is configured globally for all users but common is the only GUI user
+ file.".gvimrc".text = ''
+ set guifont=Iosevka\ 10
+ set linespace=2
+ set guioptions=agim
+ set guioptions-=m
+ 2match SpecialKeyTab /\t/
+ '';
+ };
+
+ gtk = {
+ gtk2.extraConfig = ''
+ style "vimfix" { bg[NORMAL] = "#161616" }
+ widget "vim-main-window.*GtkForm" style "vimfix"
+ '';
+ };
+}