aboutsummaryrefslogtreecommitdiff
path: root/gui/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/vim.nix')
-rw-r--r--gui/vim.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/gui/vim.nix b/gui/vim.nix
index 76912e6..09c51e1 100644
--- a/gui/vim.nix
+++ b/gui/vim.nix
@@ -26,9 +26,17 @@
};
gtk = {
- gtk2.extraConfig = ''
- style "vimfix" { bg[NORMAL] = "#161616" }
- widget "vim-main-window.*GtkForm" style "vimfix"
+ gtk3.extraCss = ''
+ window#vim-main-window {
+ background-color: #161616;
+ }
'';
};
+
+ programs.fish = {
+ enable = true;
+ shellAliases = {
+ nvim-qt = "nvim-qt --no-ext-tabline ^ /dev/null > /dev/null";
+ };
+ };
}