aboutsummaryrefslogtreecommitdiff
path: root/gui/gtk.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-08-27 21:10:56 +0200
committerAdrian Kummerlaender2020-08-27 21:10:56 +0200
commit290c1c8116cd70cc248cf4bb9458611a16c5694a (patch)
tree7a2e824dd593e31ba5878b419460d543473d85a3 /gui/gtk.nix
parent191438718de6175cb0cff457005ed312cc4e8fd8 (diff)
downloadnixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.gz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.bz2
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.lz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.xz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.zst
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.zip
Use niv for tracking channel versions
This way the config is actually reproducible without manually tracking supported nixpkgs states. home-manager is now not installed environment-wide anymore but only available inside a nix-shell.
Diffstat (limited to 'gui/gtk.nix')
-rw-r--r--gui/gtk.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/gui/gtk.nix b/gui/gtk.nix
index 2251507..b26a626 100644
--- a/gui/gtk.nix
+++ b/gui/gtk.nix
@@ -1,14 +1,15 @@
-{ config, pkgs, ... }:
+{ config, pkgs, pkgs-personal, ... }:
let
hidpi = config.custom.hidpi;
+
in {
gtk = {
enable = true;
theme = {
name = "oomox";
- package = config.custom.pkgs.oomox-gtk-theme {
+ package = pkgs-personal.oomox-gtk-theme {
accent_bg = "aadb0f";
bg = "d8d8d8";
fg = "101010";
@@ -37,7 +38,7 @@ in {
iconTheme = {
name = "oomox-archdroid";
- package = config.custom.pkgs.oomox-archdroid-icon-theme "909636";
+ package = pkgs-personal.oomox-archdroid-icon-theme "909636";
};
font = {