aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2514635
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,36 @@
+cmake_minimum_required(VERSION 2.8)
+project(DictzipQuery)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++0x -W -Wall -Wextra -Winline -pedantic"
+)
+
+include_directories(
+ src/
+)
+
+add_library(
+ DictzipQuery
+ SHARED
+ src/istream/stream.cc
+ src/istream/buffer.cc
+)
+
+add_executable(
+ example
+ example.cc
+)
+
+target_link_libraries(
+ example
+ DictzipQuery
+ z
+)
+
+install(
+ TARGETS
+ DictzipQuery
+ LIBRARY DESTINATION
+ lib
+)