aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-10 22:59:46 +0200
committerAdrian Kummerländer2014-05-10 22:59:46 +0200
commit0cd17b0afde7fc97584af31dfdfc376ef6906517 (patch)
tree861a4eb186308e333fa0e1cf01ddd47fd0e61e14 /CMakeLists.txt
parenteb854e72efa780fd6ceb6e7457b6ac6429a54dad (diff)
downloadInputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar.gz
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar.bz2
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar.lz
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar.xz
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.tar.zst
InputXSLT-0cd17b0afde7fc97584af31dfdfc376ef6906517.zip
Added test case command target as a default target
* fixed compiler flag variable (previous content was deleted)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb3e319..5173ef4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ project(InputXSLT)
set(
CMAKE_CXX_FLAGS
- "-std=c++11 -W -Wall -Wextra -Winline -pedantic -g"
+ "${CMAKE_CXX_FLAGS} -std=c++11 -W -Wall -Wextra -Winline -pedantic"
)
include_directories(
@@ -49,9 +49,13 @@ target_link_libraries(
${Libraries}
)
-add_custom_command(
- TARGET
+add_custom_target(
+ testcase
+ ALL
+ WORKING_DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}/test/
+ COMMAND
+ sh check.sh
+ DEPENDS
test
- POST_BUILD COMMAND
- cd ../test && ./check.sh
)