aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-08 20:14:35 +0200
committerAdrian Kummerländer2014-05-08 20:14:35 +0200
commit209f0b2fd9310f503d4599b12483fddc04d1f7dd (patch)
tree6ef70e3d00871ecd122db6e3bce7db6e5477f1f9 /CMakeLists.txt
parent168537848c7317f81ba44d0986e6cd7da2afb976 (diff)
downloadInputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar.gz
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar.bz2
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar.lz
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar.xz
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.tar.zst
InputXSLT-209f0b2fd9310f503d4599b12483fddc04d1f7dd.zip
Removed gtest based test cases and added program options
* selectively testing document construction in plain C++ code has turned out to be more work than worth it ** i.e. removed test cases and GTest dependency * added boost::program_options based frontent to InputXSLT ** example command: "./test --transformation ../dummy/transform.xsl --target out.xml" ** the plan is to use a simple shell script that generated test transformations and compares the output to reference files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 14 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53fa29c..b6229ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,9 +10,18 @@ include_directories(
src/
)
-add_library(
+set(
+ Libraries
InputXSLT
- STATIC
+ xalan-c
+ xerces-c
+ boost_system
+ boost_filesystem
+ boost_program_options
+)
+
+set(
+ Sources
src/plattform_guard.cc
src/transformation_facade.cc
src/function/read_file.cc
@@ -24,32 +33,17 @@ add_library(
)
add_executable(
- example
- example.cc
-)
-
-add_executable(
test
test.cc
- tests/function_read_file.cc
)
-set(
- Libraries
+add_library(
InputXSLT
- xalan-c
- xerces-c
- boost_system
- boost_filesystem
-)
-
-target_link_libraries(
- example
- ${Libraries}
+ STATIC
+ ${Sources}
)
target_link_libraries(
test
- gtest
${Libraries}
)