aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-19 15:01:33 +0200
committerAdrian Kummerländer2014-04-19 15:01:33 +0200
commit334efe3383c436d61a8e5dd95b923cb0d5db9652 (patch)
tree591f2ab70e64fef5e74077000cfb010365fc5ce9 /CMakeLists.txt
parent6c205f4859588fc8dad786dce5f2fa32c75fd3f3 (diff)
downloadInputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar.gz
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar.bz2
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar.lz
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar.xz
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.tar.zst
InputXSLT-334efe3383c436d61a8e5dd95b923cb0d5db9652.zip
Further code style fixes
* .. in the face of the planned development of usable external functions using the current proof-of-concept coding * replaced usage of std::shared_ptr in FunctionReadXmlFile class with explicit implementation of default and copy constructor * separated implementation and interfaces
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aadb81..aa6310b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,9 @@ include_directories(
add_executable(
test
test.cc
+ src/utility.cc
+ src/function/read_file.cc
+ src/function/read_xml_file.cc
)
target_link_libraries(