aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-19 22:14:31 +0200
committerAdrian Kummerländer2014-05-19 22:14:31 +0200
commit426265b91d4533b7aa16d53124ad9b5d0a6862d6 (patch)
tree8d42a9e3b27229bad9a194191ca42f32f9717972 /CMakeLists.txt
parentd19a195985b96701b2ab302538fe24e87e76decf (diff)
downloadInputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar.gz
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar.bz2
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar.lz
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar.xz
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.tar.zst
InputXSLT-426265b91d4533b7aa16d53124ad9b5d0a6862d6.zip
Implemented external "resolve-include" function
* resolves paths provided as strings against include paths provided through the newly created "--include" argument of the test executable * this was implemented to enable central collections of XSLT libraries simmilar to how there are C headers in "/usr/include"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ffcb49..c5aa8ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ set(
src/function/read_xml_file.cc
src/function/read_directory.cc
src/function/transform.cc
+ src/function/resolve_include.cc
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
src/support/xalan_string.cc