aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-23 21:26:58 +0200
committerAdrian Kummerländer2014-04-23 21:26:58 +0200
commit525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf (patch)
tree6044c2876a55ed4c794bd577909225c49015d402 /CMakeLists.txt
parent30ae1cc66daf8acbb556ec761f96690a2fa74637 (diff)
downloadInputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar.gz
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar.bz2
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar.lz
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar.xz
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.tar.zst
InputXSLT-525aa8c4dc3e23f0369c7edb1fb507ecad5f43bf.zip
Fixed xerces DOM construction related memory leaks
* Wrapped xerces DOM and support class instances in now DomDocumentGuard scope-guard class * FunctionReadDirectory class contains interal std::stack instance to store DomDocumentGuard instances ** wrapped in std::shared_ptr as FunctionReadDirectory is internally cloned by xalan... ** this is needed as the DOM has to preserved longer than the external function execution scope * Sadly XMLCh xerces strings have to be manually released ** added appropriate xercesc::XMLString::release calls * xalan::XercesDOMWrapperParsedSource does not mirror a given xerces DOM but convert it on instantiation ** this is why there is a dedicated finalize member method in InputXSLT::DomDocumentGuard * In short: I do not like the amount of trickery needed to simply prevent memory leaks in this context ** there sadly doesn't seem to be a substantially easier way to return arbitrary DOM trees from a external function
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 915a05d..94ade96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,7 @@ add_executable(
src/function/read_xml_file.cc
src/function/read_directory.cc
src/support/filesystem_context.cc
+ src/support/dom_document_guard.cc
)
target_link_libraries(