aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-28 21:51:39 +0200
committerAdrian Kummerländer2014-05-28 21:51:39 +0200
commit5859cb6af4a5136a96971c47e41e6195007ef944 (patch)
tree77431a85377b3b3742bcdb6c30526d957f9f61c1 /CMakeLists.txt
parent802d416040aa31d72defa7a9227cd31b0885bc60 (diff)
downloadInputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar.gz
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar.bz2
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar.lz
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar.xz
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.tar.zst
InputXSLT-5859cb6af4a5136a96971c47e41e6195007ef944.zip
Implemented basic ErrorHandler
* InputXSLT::ErrorHandler is derived from xercesc::ErrorHandler and enables contextual printing of transformation errors ** currently this means that the error messages passed to std::cerr contain the full path of the offending transformation * added input trimming to the external transform function ** calls to this function from inside a transformation may contain unnecessary whitespace characters which disrupt further processing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1943a13..8d83c0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,7 @@ set(
src/support/stylesheet_parameter_guard.cc
src/support/xalan_string.cc
src/support/include_entity_resolver.cc
+ src/support/error_handler.cc
src/support/tuple/xobject_value.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc