aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-06-07 17:24:44 +0200
committerAdrian Kummerländer2014-06-07 17:24:44 +0200
commit5f6fc45749b99e9013f04c95a525f2d627db01bf (patch)
tree6ba7598c874b89e893fb9b5f66e2cf26a85ac063 /CMakeLists.txt
parent272b34c1a4639cd0f909bfb52d30339c93b0c42b (diff)
downloadInputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar.gz
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar.bz2
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar.lz
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar.xz
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.tar.zst
InputXSLT-5f6fc45749b99e9013f04c95a525f2d627db01bf.zip
Improved FunctionBase constructDocument parameter propagation
* replaced std::tuple constructing Mapper template methods with direct XObjectArgVectorType unpacking ** XObjectValue::get template method is applied directly using parameter pack unpacking * implemented custom IndexSequence / Sequence type to provide vector indexes * modified all external functions to provide matching constructDocument overloads
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0b5b97..1aeec10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,7 +36,7 @@ set(
src/support/error/error_multiplexer.cc
src/support/error/error_capacitor.cc
src/support/error/warning_capacitor.cc
- src/support/tuple/xobject_value.cc
+ src/support/type/xobject_value.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc
src/support/dom/result_node_facade.cc