aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-14 20:55:51 +0200
committerAdrian Kummerländer2014-05-14 20:55:51 +0200
commit5fbca0993146982ab1dbb0d352c1e15e40b3de22 (patch)
tree7f47a339fb61d5c8423162482494eafd95cc654d /CMakeLists.txt
parent943768ad437011756395b86958399992e6822604 (diff)
downloadInputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar.gz
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar.bz2
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar.lz
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar.xz
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.tar.zst
InputXSLT-5fbca0993146982ab1dbb0d352c1e15e40b3de22.zip
Moved responsibility for argument conversion to FunctionBase descendants
* external functions may expect arguments with a type different from boost::filesystem::path so they are only provided raw string values * moved xalan string conversion logic into separate compilation unit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da44f2b..73443c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,7 @@ set(
src/function/transform.cc
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
+ src/support/xalan_string.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc
)