aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2014-09-14 19:49:15 +0200
committerAdrian Kummerlaender2014-09-14 19:49:15 +0200
commit8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25 (patch)
tree55997e02cbcaa5cf2d961dc33a1ff7ca2981ec95 /CMakeLists.txt
parentced9f340e88e6011376fb65ae81bf2f2b327ecc0 (diff)
downloadInputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar.gz
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar.bz2
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar.lz
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar.xz
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.tar.zst
InputXSLT-8ebea90f5cee70654ab9f1c19ed4f89dfc8ffb25.zip
Switched member initialization to std::make_unique
* i.e. InputXSLT now requires a C++14 supporting compiler / standard library implementation * this was done while enabling the StreamInputSource to handle all kinds of streams ** this in turn is required to enable e.g. stdin as transformation source while preserving the correct filesystem context
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f933aeb..705ecb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ project(InputXSLT)
set(
CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} -std=c++11 -W -Wall -Wextra -Winline -pedantic"
+ "${CMAKE_CXX_FLAGS} -std=c++14 -W -Wall -Wextra -Winline -pedantic"
)
include_directories(