aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-12 18:49:24 +0200
committerAdrian Kummerländer2014-05-12 18:49:24 +0200
commitc4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d (patch)
treed76ed8e9934ac6b79aabf76a7f401cfa72d37f7b /CMakeLists.txt
parent20fca5978b55606062cdaf4c94dec82f5318a62a (diff)
downloadInputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar.gz
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar.bz2
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar.lz
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar.xz
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.tar.zst
InputXSLT-c4fcfa9b39d9c29ecbc3ac1c12b7e5b2beb24a6d.zip
Implemented basic external transform function
* "InputXSLT:transform" expects two input arguments and executes the given transformation into the given target file ** this function respresents a important step in the direction of making it possible to write an actual static site generator on top of InputXSLT using XSLT * added basic "transform" test case * updated README.md to include this new function
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5173ef4..da44f2b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ set(
src/function/read_file.cc
src/function/read_xml_file.cc
src/function/read_directory.cc
+ src/function/transform.cc
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
src/support/dom/document_cache.cc